ChaosBlog

Microsoft Unternehmens­portal auf Huawei-Telefonen

14. Dec 2018
ca. 2 Minuten

Ein Huawei-Gerät in Verbindung mit dem Microsoft Unternehmensportal ist eine schwierige Kombination

Mein privates Telefon synchronisierte seit ein paar Tagen keine Mails mehr. Für die Synchronisation müssen alle Geräte explizit den Sicherheitsrichtlinien der Firma entsprechen. Trotz der Erfüllung dieser Anforderungen wollte partout keine Mail mehr synchronisiert werden, vielmehr informierte mich immer wieder eine automatische Mail, dass ich doch das Unternehmensportal (früher Microsoft Intune bzw. Company Portal) installieren soll … cleverer Tipp…

Nach einer kurzen Rücksprache mit den Firmenadmins hat sich herausgestellt, dass die Geräteprofile heimlich auf Android for Work umgestellt wurden, was bedeutete, dass das bisherige Profil meines Geräts einfach nicht mehr funktionieren konnte. Allerdings zeigte sich bei der Neuinstallation des Unternehmensportals, dass die App beim Deployment des Android for Work-Profils ständig mit einem schwarzen Bildschirm hängen blieb. Das Arbeitsprofil wurde zwar unter Konten im Telefon angezeigt, leider aber wurde das Deployment wohl wegen des Einfrierens nie beendet.

Nach gefühlt tausenden Installationsversuchen, dem Löschen des Caches und Neuinstallationen war ich schon kurz vor der Aufgabe, da auch die Rezensionen in Zusammenhang mit Huawei-Geräten nichts positives verlauten ließen.

Nichtsdestotrotz bin ich bei meiner Suche im Netz doch noch fündig geworden. In einem Thread über Huawei und das Unternehmensportal steckte die Lösung zum Problem, die bei mir minimal abgeändert funktionierte:

  1. Work-Profil unter Konten restlos entfernen
  2. Appeinstellungen von Unternehmensportal: Stoppen/Beenden erzwingen
  3. App-/Speichereinstellungen von Unternehmensportal: alle Daten komplett löschen
  4. Android Einstellungen / Akku / Starten: hier auf Manuell verwalten stellen

Mit der letzten Einstellung wird das recht aggressive Akkumanangement für die App unterbunden und bei einem neuen Anmeldeversuch im Unternehmensportal konnte bei mir Android for Work vollständig installiert werden.

Zusätzlicher Tipp: wenn die Firma noch zusätzlich ein vorkonfiguriertes Exchange-Profil für Gmail ausrollt, dann einfach lange warten. Mein vorzeitig selbst angelegtes Exchange-Konto konnte leider trotzdem nicht genutzt werden. Nach einer kompletten Neuinstallation, warten, immer wieder Einloggen ins Unternehmensportal und auch mal einem Neustart war plötzlich das Exchange-Konto gepusht und nutzbar!


Read more...
Cookie-Richtlinie

Diese Website benutzt Cookies, u.a. zur automatisierten Nutzerauswertung mit Google Analytics.

Bitte beachten Sie die Datenschutzerklärung!